Maintenance taking longer than expected
Incident Report for Ryver, Inc
Resolved
Maintenance has been completed. Thank you for your patience!
Posted almost 2 years ago. Mar 31, 2017 - 04:52 UTC
Investigating
The Server Upgrade is taking a bit longer than expected. We are investigating the state of one of the servers now.
Posted almost 2 years ago. Mar 31, 2017 - 04:35 UTC